*


All times are UTC + 1 hour



Post new topic Reply to topic
 [ 2 posts ] 
Author Message
 Post subject: my pump is losing air from the deflate part
PostPosted: Tue Oct 12, 2010 6:31 pm 
Offline
Rare Poster

Joined: Sun Sep 07, 2008 11:14 pm
Posts: 25
anyone knows how can i fix that?


{ SHARE_ON_FACEBOOK } { SHARE_ON_TWITTER } { SHARE_ON_ORKUT } { SHARE_ON_DIGG } { SHARE_ON_MYSPACE } { SHARE_ON_DELICIOUS }
Top
Profile
 Post subject: Re: my pump is losing air from the deflate part
PostPosted: Mon May 13, 2013 4:50 pm 
Offline
Very Frequent Poster
User avatar

Joined: Thu Feb 08, 2007 5:12 pm
Posts: 1133
Location: CubaKiteLessons.com
OK old post but I just fixed the same problem. My pump was pumping very little air and no pressure. Like in this old post the air was escaping trough deflate end. I took the whole thing apart. There is a smaller tube inside the pump shaft. When you reassemble make sure that that piece is centered thus it possible to screw the handle and the piston all the way. Otherwise there is a leak and no pressure.


Top
Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic
 [ 2 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: Bing [Bot], deniska, Do-it, Google [Bot], peterbjarke, randycasburn, Sean7210, Tone and 27 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group