*


All times are UTC + 1 hour



Post new topic Reply to topic
 [ 18 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Mystic clickerbar 3.0 failed
PostPosted: Tue Jun 25, 2013 7:37 pm 
Offline
Rare Poster
User avatar

Joined: Sun May 06, 2012 10:06 pm
Posts: 25
This afternoon I had a session in 40-45 kmh wind and after about 90 mind riding, the clickerbar on my Warrior 3 harness opened during a jump! :o
I noticed that something weird is going on, looked down and scared sh!tless... the strap securing the bottom part of the bar was the only thing holding my kite.
Luckily I was relatively close to shore and the water was shallow so I managed to land the kite safely on the beach.

The lock pin is twisted and its not possible to put it the lock mechanism. Has anyone experienced similar spontaneous releases on mystic harnesses? Thanks god the securing strap was able to hold my weight.

The pin won't go all the way inside the lock mechanism as shown here.
Attachment:
IMG_20130625_194625.jpg
IMG_20130625_194625.jpg [ 1.23 MIB | Viewed 1197 times ]


The twisted pin
Attachment:
IMG_20130625_194640.jpg
IMG_20130625_194640.jpg [ 659.47 KIB | Viewed 1197 times ]


{ SHARE_ON_FACEBOOK } { SHARE_ON_TWITTER } { SHARE_ON_ORKUT } { SHARE_ON_DIGG } { SHARE_ON_MYSPACE } { SHARE_ON_DELICIOUS }
Top
Profile
 Post subject: Re: Mystic clickerbar 3.0 failed
PostPosted: Tue Jun 25, 2013 7:47 pm 
Offline
Very Frequent Poster
User avatar

Joined: Mon Sep 24, 2001 1:00 am
Posts: 29287
Location: World (KF Admin)
Thx for the info.

Did you send an email to Mystic? If not, you should do so they are aware of the problem.


Top
Profile
 Post subject: Re: Mystic clickerbar 3.0 failed
PostPosted: Tue Jun 25, 2013 8:44 pm 
Offline
Frequent Poster
User avatar

Joined: Thu Feb 12, 2009 9:50 pm
Posts: 358
dang i've never seen that before!


Top
Profile
 Post subject: Re: Mystic clickerbar 3.0 failed
PostPosted: Tue Jun 25, 2013 11:08 pm 
Offline
Very Frequent Poster

Joined: Tue May 01, 2007 1:11 pm
Posts: 512
HOLY SHIT!!!cant imagine this to happen to the new harnesses(i wear the new majestic 2013) cause they got no holding belt


Last edited by nikalaitzian on Thu Jun 27, 2013 8:30 pm, edited 1 time in total.

Top
Profile
 Post subject: Re: Mystic clickerbar 3.0 failed
PostPosted: Wed Jun 26, 2013 5:48 am 
Offline
Medium Poster
User avatar

Joined: Thu Oct 06, 2011 8:36 am
Posts: 113
This is the first time i have ever heard of this.
Been riding mystic for a while now, most of my bodies are riding Mystic as well, and never happened to anyone around here.


Top
Profile
 Post subject: Re: Mystic clickerbar 3.0 failed
PostPosted: Wed Jun 26, 2013 2:16 pm 
Offline
Frequent Poster

Joined: Thu Jun 16, 2011 2:21 am
Posts: 402
For me at 220 lbs thats just normal for me,everything I use breaks,boards,bars,spreaders,harnesses and the list goes on and on. :cry: Are you doing hooked in kite loops?I've found in the higher winds lots of stress on equipment. Especially backroll loops.lots of stress from weird angles.


Top
Profile
 Post subject: Re: Mystic clickerbar 3.0 failed
PostPosted: Wed Jun 26, 2013 2:25 pm 
Online
Very Frequent Poster

Joined: Tue Dec 23, 2003 2:34 pm
Posts: 1429
pj sofine wrote:
For me at 220 lbs thats just normal for me,everything I use breaks,boards,bars,spreaders,harnesses and the list goes on and on. :cry: Are you doing hooked in kite loops?I've found in the higher winds lots of stress on equipment. Especially backroll loops.lots of stress from weird angles.



I am 230 and don't accept stuff breaking.

My lines are over engineered, my harness should be over engineered.

I have had the same issue with my 3.0 clicker, it came undone twice. Mystic sent me another one which is fine.

Looks like a dodgy batch.

Not good, but they did react and replace.

Tony


Top
Profile
 Post subject: Re: Mystic clickerbar 3.0 failed
PostPosted: Wed Jun 26, 2013 3:22 pm 
Offline
Rare Poster
User avatar

Joined: Sun May 06, 2012 10:06 pm
Posts: 25
pj sofine wrote:
For me at 220 lbs thats just normal for me,everything I use breaks,boards,bars,spreaders,harnesses and the list goes on and on. :cry: Are you doing hooked in kite loops?I've found in the higher winds lots of stress on equipment. Especially backroll loops.lots of stress from weird angles.

I was not doing kiteloops just regural jumps, rotations, etc. My weight is 80kg but IMHO all this is irrevelant, since this should not happen at any circumstances even a heavier rider doing kiteloops.

Apart from this issue I am really happy with the harness so far and sometimes even the most reliable equipment fails, I was just curious if its a known issue.

The worst part of all is that I will be off for a kite holiday this Saturday and its pretty unlikely that my problem will be solved by then. I sent an email Yesterday afternoon to the retailer (bought the harness online from Germany) explaining all the details but they haven't replied yet.

Luckily I will be able to borrow a harness for my holiday, but its a mystic aviator seat... :cry:

I will contact Mystic as well but will wait for the retailer's reply first.


Top
Profile
 Post subject: Re: Mystic clickerbar 3.0 failed
PostPosted: Wed Jun 26, 2013 3:48 pm 
Offline
Very Frequent Poster
User avatar

Joined: Thu May 31, 2007 12:41 pm
Posts: 649
Location: Montreal, Canada / NJ, USA
First of all - it looks like it haven't quite "clicked" when you closed the buckle, hence it was slowly working its way out until reaching the recessed part which got bent and at which point it fully released.

Second - unless it's cracked, there's really no reason why you can't simply hammer it back straight and use until they'll send you a new one. This is a fairly soft steel, so no worries. Just make sure it "clicks" when you close it. The recessed part isn't subjected to any heavy loads anyways, it's the long, straight neck that does all the work.

Cheers!


Top
Profile
 Post subject: Re: Mystic clickerbar 3.0 failed
PostPosted: Wed Jun 26, 2013 4:44 pm 
Offline
Rare Poster
User avatar

Joined: Sun May 06, 2012 10:06 pm
Posts: 25
alexeyga wrote:
First of all - it looks like it haven't quite "clicked" when you closed the buckle, hence it was slowly working its way out until reaching the recessed part which got bent and at which point it fully released.

Second - unless it's cracked, there's really no reason why you can't simply hammer it back straight and use until they'll send you a new one. This is a fairly soft steel, so no worries. Just make sure it "clicks" when you close it. The recessed part isn't subjected to any heavy loads anyways, it's the long, straight neck that does all the work.

Cheers!

It clicked and I always double check if the mechanism is closed. I was riding more than an hour before it unclipped so I guess that it was no "user error".

I'm not sure about "hammering it back" as multiple bends could weaken the material so next time it could break. Maybie its OK to do it but I don't want the same scenario happening again.

The main problem is not the bended pin (as it was OK before it unclipped), but probably the locking mechanism which let the pin to unclip under heavy load. So no matter if I hammer the pin back if the mechanism will let the clip go again.


Top
Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic
 [ 18 posts ]  Go to page 1, 2  Next

All times are UTC + 1 hour


Who is online

Users browsing this forum: Bing [Bot], lollypop, Yahoo [Bot] and 30 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group