Contact   Imprint   Advertising   Guidelines

Anyone with issues on Ozone fast inflation?

forum for kitesurfers


markchatwin
Very Frequent Poster
Posts: 527
Joined: Sun Dec 10, 2006 4:10 pm
Kiting since: 0
Brand Affiliation: None

Anyone with issues on Ozone fast inflation?

Postby markchatwin » Tue Nov 05, 2013 9:07 pm

I've got a 2013 Zephyr I'm interested in and the guy says that when they 1st pumped it up it leaked through the valve. He said he didn't tighten it all the way. I can't seem to find a picture of the Ozone system to see what he's talking about. He says he torques it down really tight and it seems to hold air. Do folks with this system have to torque it tight or could there be a flaw to this system? TX

User avatar
Marty
Frequent Poster
Posts: 340
Joined: Wed Aug 27, 2003 3:38 am
Kiting since: 0
Brand Affiliation: None
Location: Utah

Re: Anyone with issues on Ozone fast inflation?

Postby Marty » Tue Nov 05, 2013 10:02 pm

It has to be tightened very tight.
Just like any "Boston Valve" type valve.
I remember having to crank down my Cabrinha's '04 ish
or they would leak also.
Unlike the old valves, the Ozone wont twins the baldder inside the kite.

Crank the bitch down, no problem..

Lots of pictures here http://tinyurl.com/no9j8f2

(of course cranking it down, can mean more to some than to others, tight is tight)
Last edited by Marty on Wed Nov 06, 2013 2:56 am, edited 2 times in total.

badgb21
Frequent Poster
Posts: 255
Joined: Mon Jun 16, 2003 8:55 am
Kiting since: 2004
Gear: C/Fly, Shinn, Ozone, Cabrinha
Brand Affiliation: None
Location: Hants UK

Re: Anyone with issues on Ozone fast inflation?

Postby badgb21 » Tue Nov 05, 2013 10:32 pm

Once you've blown any sand away and ready to screw in the valve, spit on your finger and rub it around the sealing surface on the kite. This will help.

Kev

Westozzy
Very Frequent Poster
Posts: 2918
Joined: Sat Jun 30, 2012 11:25 am
Kiting since: 12
Local Beach: Mandurah
Style: Freeride, wave
Gear: Rebel, Vegas 2012
Brand Affiliation: None

Re: Anyone with issues on Ozone fast inflation?

Postby Westozzy » Tue Nov 05, 2013 10:57 pm

Funny I asked the same question a while back. While yes right is good there is no need to go over the top. The advice given to me which is said above is before you pump take off the black seal and make sure there is no sand especially below the side that sits on the plastic valve.

Just blow it off. Never needed to spit on it but that would help I suppose. Even the slightest bit of sand can cause it to slowly leak. I only do this though every couple of kites. No biggy.

Then you needn't torque it down as much.

yuko
Medium Poster
Posts: 51
Joined: Tue Aug 14, 2012 1:31 am
Kiting since: 1
Local Beach: Oka
Gear: Airush
Brand Affiliation: None

Re: Anyone with issues on Ozone fast inflation?

Postby yuko » Tue Nov 05, 2013 11:35 pm

Westozzy wrote:Funny I asked the same question a while back. While yes right is good there is no need to go over the top. The advice given to me which is said above is before you pump take off the black seal and make sure there is no sand especially below the side that sits on the plastic valve.

Just blow it off. Never needed to spit on it but that would help I suppose. Even the slightest bit of sand can cause it to slowly leak. I only do this though every couple of kites. No biggy.

Then you needn't torque it down as much.


+1 for what Ozzy says, had my 15m Edge slowly deflate the other day. Problem was the sand UNDER the rubber seal, blow it all off and make sure all surfaces are squeaky clean. Afterwads, tigthen your valve Normally, no need to tighen more than usual at all and she'll be back in business. :jump:


Return to “Kitesurfing”

Who is online

Users browsing this forum: slim_charles, Yahoo [Bot] and 20 guests