Contact   Imprint   Advertising   Guidelines

Rhino 05 18m strut bladder problems???

Find reviews of kites, boards and accessories


NeverAlive
Rare Poster
Posts: 19
Joined: Wed Dec 31, 2003 12:18 am

Rhino 05 18m strut bladder problems???

Postby NeverAlive » Sun May 08, 2005 3:57 pm

Been having some problems with my 18m rhino 05, where the strut bladders seem to pop/burst about an inch above the valve towards the leading edge. 3 bladders have gone all in the same place on two different struts... it is not by over inflating.

I also have a 10 and a 14 which I have had no problems with. All kites are packed the same way, folded wingtip to wingtip and then rolled to the middle.

anyone else has had problems of this sort or this is a one off???


I believe the 18 is already the second version of the rhino 5s with protection on the wingtips because of the wing rods.


cheers

User avatar
Wawando
Very Frequent Poster
Posts: 2438
Joined: Mon Sep 08, 2003 9:21 pm
Kiting since: 0
Brand Affiliation: None
Location: Portugal - Guincho; Rebel2012 5m, 9m & 2011 7m; Amundson 5'9&6'

Postby Wawando » Sun May 08, 2005 4:30 pm

Check that bladder tube is well inserted into the outside tissue. I had that problem with one of the R05 12m bladders because it was not well inserted so to fill the space, the bladder blew .

Dwight
Very Frequent Poster
Posts: 3208
Joined: Thu Aug 08, 2002 1:00 am
Kiting since: 1999
Gear: Any
Brand Affiliation: None

Postby Dwight » Sun May 08, 2005 10:17 pm

The struts that are not union struts, have pointed ends near the leading edge. Sometimes the bladder does not get inserted up into that pointed end. Once the rib is pumped hard, feel the pointed end and see if the bladder has filled the whole strut up into the pointed end. If not, add some soapy water and work it into the pointed end with your hand before using high pressure.


Return to “Reviews”

Who is online

Users browsing this forum: No registered users and 2 guests