Contact   Imprint   Advertising   Guidelines

wipika 2002 airblast jellyfishing something bad, comments?

forum for kitesurfers


pclarky
Rare Poster
Posts: 6
Joined: Fri Sep 06, 2002 1:00 am

Postby pclarky » Fri Sep 06, 2002 12:02 pm

Just puchased this kite had a couple of goes
in light wind and it seemed ok. I removed the
bridle and it flew about the same with out the really light feel to the bar.
I've just had a kite in about 16knts and it flew like a pig, it wouldn't hold its shape, the leading edge was pumped up solid. It was so bad I packed up . One of the worst sessions I've had in 1.5 years of kiting in wind which didnt' seem to be that gusty. If this is normal for an airblast
I will have to go back to my 2001 Cabrinha BT, Yep ,I seem to pick the dud kites. Any comments or advice would be appreciated.

Guest

Postby Guest » Fri Sep 06, 2002 12:26 pm

This is the second AB I heard of with this problem. Was talk to a lad the wknd with an 2002 11.8 and the kite wasn't flying well at all. Think he's being it back to.

Hernan
Very Frequent Poster
Posts: 734
Joined: Tue Aug 13, 2002 1:00 am
Kiting since: 0
Brand Affiliation: None

Postby Hernan » Fri Sep 06, 2002 1:48 pm

I fly airblast and i m very happy with them. If you remove the bridle, the depower is not as progressive. The depower range setting of the wipis bar is too long for non bridle kites. Try making a knot on de depowerline to shorten its range. Surely if you move the bar too much the kite would jellyfish.

JMF
Frequent Poster
Posts: 477
Joined: Mon Sep 02, 2002 1:00 am
Kiting since: 2000
Brand Affiliation: None
Location: Teahupo'o, Tahiti

Postby JMF » Mon Sep 09, 2002 10:04 am

Hi

I have also had this problem over the weekend with a new AB 11.8 2002 (no briddle). I spoke to one of the more seasoned Wipika riders and he said what you need to do is get your kite up in the air pull your bar down about 3/4 of the way then adjust your power by pulling down on the adjuster (camcelt) until the wing tips pull in. I aslo fly a 2002 AB 8.4 with briddle Aand I never had this problem.

User avatar
MissionMan
Very Frequent Poster
Posts: 1942
Joined: Wed Aug 14, 2002 1:00 am
Kiting since: 0
Brand Affiliation: None
Location: Melbourne, Australia

Postby MissionMan » Mon Sep 09, 2002 10:12 am

I think its one of those weird things as Justin (Wipirider) says. I saw a couple of Airblasts out on the day, and only a small amount of the 11.8's were jellyfishing so, it has to be setup.

prankster
Rare Poster
Posts: 35
Joined: Tue Apr 23, 2002 1:00 am
Kiting since: 0
Brand Affiliation: None
Contact:

Postby prankster » Mon Sep 09, 2002 11:06 am

This is something that happened top early 10.0s but from then, and more now with the latest designs hich are made in Dacron, jellyfishing does not occur any more. No need even ror finetuning the kite. Just plug and ply. The only thing you have to be aware of is not over-powering the kite or it will stall as the tips will open too much. 2002 wipis are great kites, with great performances and probably the best bar available.

pclarky
Rare Poster
Posts: 6
Joined: Fri Sep 06, 2002 1:00 am

Postby pclarky » Mon Sep 09, 2002 11:30 am

Thanks everyone for the tips. I tend to agree
that it's in the setup. I kited with another
wipika 2002 owner the other day and his kite was sweet, didn't seem to jellyfish at all.
He had the locking system on the chicken loop, so it's probaly me moving the bar too
much. It's the same system I ran on my other
kites and never had this problem, anyway
got a few ideas to try on the weekend
thanks again


Return to “Kitesurfing”

Who is online

Users browsing this forum: No registered users and 15 guests