Contact   Imprint   Advertising   Guidelines

X2 durability

forum for kitesurfers


Postby Guest » Fri Aug 16, 2002 9:05 am

After using my brand new X2 about 8 times I noticed a 1 inch hole in
the fabric of the front bladder. It's along the reinforcement band
that goes from the struts to the front bladder. It happend on the
middle strut.
The kite has newer been crashed hard or over inflated.
Has anyone experienced the same problem and does anyone know about
the varanty for such cases.

Hang Loose


EH Kiteboards
Rare Poster
Posts: 41
Joined: Mon Jul 08, 2002 1:00 am
Kiting since: 0
Brand Affiliation: None

Postby EH Kiteboards » Sat Aug 17, 2002 3:12 am

I have 200 pluss hours on my X2, it looks like new

User avatar
Rare Poster
Posts: 20
Joined: Sat Apr 13, 2002 1:00 am
Kiting since: 1999
Local Beach: Reschensee, Comersee, Urnersee
Favorite Beaches: Mauritius
Style: old scool
Gear: Wainman Hawaii, North, F-One, Concept-X
Brand Affiliation: i have an Shop in Switzerland. Wainman Hawaii
Location: Goldau CH

Postby Helloween » Sun Aug 18, 2002 6:01 pm


i have 2 X2 end i never have a problem with the tubes! i be sure you have make the hole with an litlething, on the beach.
(i ride the X2 since 4 month)



Postby Guest » Tue Aug 20, 2002 7:51 am

I also have had that problem on my x2 10. I have got 2 small holes on between the LE and the struts.

No problems with my X2 14 yet.




Postby Guest » Tue Aug 20, 2002 8:33 am

I'm going to see what Naish says about it. Hopefully they will change the kite with a new one.



Return to “Kitesurfing”

Who is online

Users browsing this forum: BCKiter123, Bing [Bot], BOEMIX and 27 guests